Churchill Management Group Online Technical Requirements

We strongly recommend that you use or upgrade to the latest version of software supported by Churchill Management Group. 

Browser Requirements

We recommend that you use the latest version of the supported browsers and keep your security settings up-to-date.  In certain circumstances, with or without notice, we may block certain browsers and software from accessing Churchill Management Group’s internet websites and client portals (“Sites”) due to possible security risks.

Churchill Management Group’s minimum encryption requirement for accessing the Sites is 128-bit encrypted browsers.

Supported browsers

We recommend using one of the following supported browsers.

Microsoft EdgeTM  (most recently published version)

Firefox®  (most recently published version)

Safari®  (most recently published version)

Google ChromeTM  (most recently published version)

PDF Requirements

While there are many pdf readers available, Churchill Management Group recommends Adobe® Reader® software to access documents being provided to you in PDF format. We recommend you keep Adobe® Reader® up to date at all times. 

For Mac users: If you access a PDF document from a Mac, the PDF may be automatically copied to its desktop or to an easily accessible download folder.

For PC users: If you access a PDF document from a PC, the PDF may remain among its cached files.

Hardware and Operating System Requirements

Please consult with your browser vendor and pdf reader regarding the minimum hardware and operating system requirements that apply to the software versions you are currently using or wish to install.

Please Note: When you make changes to your computer software or equipment, the Site may require you to re-confirm your identity the next time you visit our Site to conduct online transactions.